It may be something more specific in Swift, but the "Guard clause" concept is a clean code practice that can be used in all languages, as a way to help improve readability by keeping the code shallow. For example, instead of doing:

if a:
    if b:
        if c:
            do_stuff()

or having a long line with several conditions:

if a and b and c:
   do_stuff()

You return early:

if not a:
   return

if not b:
   return

if c:
    do_stuff() 

I always try to keep my functions below 2 levels of depth and it helps A LOT when I have to read through them hunting bugs. So, even if Godot doesn't implement Swift's guard, you will still benefit a lot from using the "regular" guard clause in GdScript (or in any language, really).