Try to export to Android but it says "apk was not installed"

falconfalcon Posts: 1Member
edited April 5 in Exporting

Please please help me
I don't know why this is happening, I have everything, debug keystore, Adb, jdk, all the project has latin characters, gles2, and anyways it doesn't work. It worked for me a week ago but now it isn't. I tried to change the version and also delete the old ones and steel nothing :(.
In the installation the error is:

 java.util.NoSuchElementException
    at java.util.ArrayList$Itr.next(ArrayList.java:863)
    at b.a.a.j.a.e.currentApk(Unknown Source:2)
    at com.apkcombo.app.installer2.impl.rootless.b.p(Unknown Source:276)
    at com.apkcombo.app.installer2.impl.rootless.b.q(Unknown Source:0)
    at com.apkcombo.app.installer2.impl.rootless.b.r(Unknown Source:0)
    at com.apkcombo.app.installer2.impl.rootless.a.run(Unknown Source:6)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:458)
    at java.util.concurrent.FutureTask.run(FutureTask.java:266)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1167)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:641)
    at java.lang.Thread.run(Thread.java:764)

If someone can help I will very appreciate it!


Tags :

Comments

  • TwistedTwiglegTwistedTwigleg Posts: 4,201Admin

    Welcome to the forums @falcon!

    How are you installing the app on the device? Are you using Android Studio, Godot, or some other method? Based on my very limited Android experience, the error above seems to be with placing the APK on the device rather than an issue with the APK itself. I would see if using an alternative method of placing the APK, like through Android Studio, fixes the issue. You could also try emailing or sending the APK to your device through something like Dropbox and see if you can install it directly from the device as well.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file