The Godot Community Forums are back up and running! Please read the the announcement post for important information on what happened. Thanks!

Godot IDE UI too cramped

LakeLake Posts: 2Member

This is what the Godot IDE looks like on my screen, which is at it's maximum resolution, 1600x1200.

I like Godot, but it is barely usable for coding. I can see max 43 characters per a line - much less when you consider tabs. That's barely half the 80 character width of the old style terminals from back in the day.

Is Godot supposed to look like this? How do you use it?

There are a number of things I'd like to turn off. Like the "filter scripts" column. Or that weird scroll bar with the shrunk down version of my code. Neither is as useful to me as seeing my code. I understand there's the "distraction free" button, which makes coding bearable, but, it keeps those two columns I don't need, and takes away the Scene, Inspector, Node, and FileSystem ones, which are actually helpful.

Is there a way I can make the IDE more user friendly?

Sorry for not being able to afford a better monitor

Comments

  • TwistedTwiglegTwistedTwigleg Posts: 3,129Admin

    You could maybe try enabling high DPI mode and see if that helps. As far as editor suggestions go, I would suggest making a proposal on the Godot proposals repository detailing the changes or chiming in on an issue that already mentions the changes if one exists on the repository.

  • cyberealitycybereality Posts: 1,053Moderator

    It looks like it's being scaled. When I started with Godot I was using a 1080p monitor (actually 2560x1080) and it was a little cramped but not as bad as your photo. Make sure Windows display scaling is at 100%. You can also override the scaling for just Godot by right-clicking the exe file and checking out the compatibility settings for high-dpi.

  • LakeLake Posts: 2Member

    Thanks for the help. I changed my text size from 150% to 125% in the personalizations options for windows 7, which makes Godot more legible, and everything else, rather less. I prefer 150% for accessibility reasons most of the time.

    It would be nice if I could change the scaling on just Godot. I tried right clicking and looking in properties, and there is a "Disable display scaling on high DPI settings" box in the Settings dialogue, it's grayed out and can't be used.

    Do I have any other options? I've never made a proposal in the repository - I feel like I would have trouble knowing what they would want to hear from me.

  • KequcKequc Posts: 137Member
    edited September 15

    Your best bet is turning off hidpi mode (or setting it to lowdpi) in your Godot settings. That should double your screen real estate.

    Or if that's already set, you might have to use more pixels at the operating system level. You are using a fairly old operating system so I don't know how those settings work.

    Or maybe I'm wrong about everything I said, I'm not sure. I never ran into your problem.

    I'm fairly certain the interface itself is customisable. You can turn off the code preview scrollbar somewhere in settings for example.

  • KequcKequc Posts: 137Member
    edited September 15

    With a script open, go File > Toggle Scripts Panel and that gets rid of that part. Actually that was bothering me too.

    You can also collapse your Output or Debugger pane by just clicking on the open tab.

  • Note that there currently is a "Distraction Free Mode" (Constrol+Shift+F11) which maximizes the coding window.
    Or, even easier, toggle the distraction free mode by clicking on the enlarge icon in the top right of your coding window.
    I hope this helps!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file