The Godot Community Forums are back up and running! Please read the the announcement post for important information on what happened. Thanks!

How to fix an alsa audio driver failure?

DominicDominic Posts: 5Member
edited September 12 in General Support

I'm using GDNative fairly extensively in my project, as the pathfinding model I'm using (my own version of all-pairs-shortest-path) needs to be as fast as possible and I decided using C++ would help with that. I only recently realised that I could build and test the code at the same time by simply pressing F5 in VSCode, running SCons and then immediately running the game with the new native code, allowing me to develop it much more easily. While this is mostly fine, two errors/warnings are constantly appearing in the output:

I've spent several hours searching through the forums a similar question has appeared on before, and have found that no-one else's solution works for my problem. Also, as far as I can tell, the others with this problem were getting it while running their project in Godot, whereas my problem only occurs while running it in VSCode.

Does anyone have any idea of how I could fix this, or what the issue might be?
Thanks in advance, Dominic

Edit: I'm using Ubuntu by the way.

Best Answer

  • DominicDominic Posts: 5
    edited September 15 Accepted Answer

    In case anyone has the same problem and finds this later on: I've now found out what the issue was. I was using the snap version of VSCode, since at the time I installed it I was new to Ubuntu and hadn't yet realised that snaps aren't that great (despite being the option that the system basically forces on you in 20.04).
    For some reason, the snap VSCode's terminal works almost unnoticeably differently from the normal terminal, but doesn't work correctly with Godot and pulse audio - to fix this, I simply uninstalled it and replaced it with the VSC debian, which now has exactly the behaviour I'd expect.

    Still not sure why Ubuntu is promoting snaps so much when they're not fully reliable yet (there are other examples of them not working properly), but I'd recommend sticking to the older debians for now (;

Answers

  • DominicDominic Posts: 5Member
    edited September 15 Accepted Answer

    In case anyone has the same problem and finds this later on: I've now found out what the issue was. I was using the snap version of VSCode, since at the time I installed it I was new to Ubuntu and hadn't yet realised that snaps aren't that great (despite being the option that the system basically forces on you in 20.04).
    For some reason, the snap VSCode's terminal works almost unnoticeably differently from the normal terminal, but doesn't work correctly with Godot and pulse audio - to fix this, I simply uninstalled it and replaced it with the VSC debian, which now has exactly the behaviour I'd expect.

    Still not sure why Ubuntu is promoting snaps so much when they're not fully reliable yet (there are other examples of them not working properly), but I'd recommend sticking to the older debians for now (;

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file