The Godot Community Forums are back up and running! Please read the the announcement post for important information on what happened. Thanks!

Transparent BG on main viewport no longer pass through mouse event.

So before i open a bug report, i want to ask this here.
So with Godot 3.2.1 i can make something like this video.
Basically I make the game bg transparent, then when running it i can interact with the windows opened behind the game.
So, when I open this project again with Godot 3.2.2 (also 3.2.3 rc 6) it cannot do that anymore.
AFAIK, the big change from 3.2.1 to 3.2.2 is 2D batching, is that the reason?
So, is it a regression? Or the devs remove this feature? Or I have to do something to do this input behaviour for 3.2.2?

Comments

  • MegalomaniakMegalomaniak Posts: 2,908Admin

    What are your mouse filtering options? Make sure to check all nodes that could affect it.

    Honestly for all I know it might have been something considered an unintended/buggy behavior and perhaps removed. Haven't tried making a completely transparent window before.

  • earlroxasearlroxas Posts: 19Member

    @Megalomaniak said:
    What are your mouse filtering options? Make sure to check all nodes that could affect it.

    i think it is ignore.

    Well, when the project opened with Godot 3.2.1 it works, when opened with 3.2.2 it isn't.
    Well, maybe I'll open bug report.

  • MegalomaniakMegalomaniak Posts: 2,908Admin

    Yeah, though might be worth searching the tracker first, perhaps someones already reported it. In that case add a comment. A confirmation is always useful.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file