The Godot Community Forums are back up and running! Please read the the announcement post for important information on what happened. Thanks!

Godot crashes on loading any project - manjaro linux

Hello!

Godot crashes on loading any project. The following is the terminal output. Maybe someone can elucidate my problem for me?

Thanks in advance

Godot Engine v3.2.2.stable.official - https://godotengine.org
OpenGL ES 3.0 Renderer: GeForce GT 1030/PCIe/SSE2

Editing project: /home/~my username~/Godot-games/B
(::home::~my username~::Godot-games::B)
Godot Engine v3.2.2.stable.official - https://godotengine.org

OpenGL ES 3.0 Renderer: GeForce GT 1030/PCIe/SSE2
handle_crash: Program crashed with signal 11
Dumping the backtrace. Please include this when reporting the bug on https://github.com/godotengine/godot/issues
[1] /usr/lib/libc.so.6(+0x3d6a0) [0x7fabb38716a0] (??:0)
[2] /usr/lib/libnvidia-glcore.so.450.66(+0xee6365) [0x7fabb103a365] (??:0)
[3] /usr/lib/libnvidia-glcore.so.450.66(+0xee75fc) [0x7fabb103b5fc] (??:0)
[4] /usr/lib/libnvidia-glcore.so.450.66(+0xb06282) [0x7fabb0c5a282] (??:0)
[5] /usr/lib/libnvidia-glcore.so.450.66(+0xb064fd) [0x7fabb0c5a4fd] (??:0)
[6] /usr/lib/libnvidia-glcore.so.450.66(+0xb08f2c) [0x7fabb0c5cf2c] (??:0)
[7] /home/~my username~/Godot_v3.2.2-stable_x11.64() [0x239ee5e] (:?)
[8] /home/~my username~/Godot_v3.2.2-stable_x11.64() [0x23a14db] (:?)
[9] /home/~my username~/Godot_v3.2.2-stable_x11.64() [0x100f2c4] (:?)
[10] /home/~my username~/Godot_v3.2.2-stable_x11.64() [0x2a6ad9d] (:?)
[11] /home/~my username~/Godot_v3.2.2-stable_x11.64() [0x85b675] (??:?)
[12] /usr/lib/libc.so.6(__libc_start_main+0xf2) [0x7fabb385c152] (??:0)
[13] /home/~my username~/Godot_v3.2.2-stable_x11.64() [0x86695e] (??:?)
-- END OF BACKTRACE --

Comments

  • MegalomaniakMegalomaniak Posts: 2,908Admin

    As per that error message you should probably report it to the issue tracker, with the backtrace included.

  • TwistedTwiglegTwistedTwigleg Posts: 3,129Admin

    Yeah, if you are getting a backtrace, you probably should make an issue on GitHub about this.

    That said, looking at the backtrace, it looks like it is related to the Nvidia stuff. Have you updated your graphics card drivers recently? If not, it may not be a bad idea to see if updating them helps.

  • As far as I can tell, I have the newest drivers, (nvidia 450.66).
    Posted it on github.
    Thanks

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file