The Godot Community Forums are back up and running! Please read the the announcement post for important information on what happened. Thanks!

Why is Godot giving me a BSoD?!?!

I've used Godot in the past and it worked fine, but recently it's been freezing and then crashing my computer (Windows 10) with a "DRIVER_POWER_STATE_FAILURE". I've looked through various guides online to fixing the error, but nothing I've done has worked. I've tried uninstalling and then reinstalling my drivers. I've tried changing the power settings on my computer. I've tried only running Godot with no other programs open. But nothing works. I can't tell what even causes Godot to freeze, and I can't predict when it will crash my computer, only that it will do it eventually. Godot is the only program that this happens on (though admittedly, I don't use many programs really). Why is this happening???

I'm not sure what to do. Should I find a different game engine?

Best Answer

  • MegalomaniakMegalomaniak Posts: 2,908
    edited September 8 Accepted Answer

    You say you have tried changing the power settings on your computer. By that I assume you mean windows settings. But if my guess is correct then it's an nvidia gpu and you will want to change a setting in the nvidia control panel. I've seen this problem come up for people using blender 3D too.

    https://www.thefpsreview.com/2019/12/04/nvidia-geforce-driver-power-mode-settings-compared/

    Try making sure it's set to "Prefer Maximum Power". Note that instead of doing it for the global profile you can also try setting up a godot executable specific profile.


    edit: to further speculate, the default option which is "optimal power" will cause the nvidia driver to control when frames are being rendered and when they are not so as to save power, but godot editor also tries to do that when godot editor is out of focus, thus the two might conflict. So its best to set it to "Prefer Maximum Power" and trust that godot editor will manage it's display updating as is appropriate for it.

Answers

  • MegalomaniakMegalomaniak Posts: 2,908Admin
    edited September 8 Accepted Answer

    You say you have tried changing the power settings on your computer. By that I assume you mean windows settings. But if my guess is correct then it's an nvidia gpu and you will want to change a setting in the nvidia control panel. I've seen this problem come up for people using blender 3D too.

    https://www.thefpsreview.com/2019/12/04/nvidia-geforce-driver-power-mode-settings-compared/

    Try making sure it's set to "Prefer Maximum Power". Note that instead of doing it for the global profile you can also try setting up a godot executable specific profile.


    edit: to further speculate, the default option which is "optimal power" will cause the nvidia driver to control when frames are being rendered and when they are not so as to save power, but godot editor also tries to do that when godot editor is out of focus, thus the two might conflict. So its best to set it to "Prefer Maximum Power" and trust that godot editor will manage it's display updating as is appropriate for it.
  • cyberealitycybereality Posts: 1,053Moderator

    What video card do you have? Have you tried using DDU safe mode to clean out the driver? Sometimes files can get corrupt and DDU can fix it.

  • I have "Intel(R) UHD Graphics 620". I tried using DDU in safe mode, but Godot still crashed after I reinstalled everything.

    I'm not using Godot to make a 3D game, though. Would setting it to "prefer maximum power" (which I did) really help in this case?

  • cyberealitycybereality Posts: 1,053Moderator
    edited September 8

    Possibly. The driver may try to adjust the power state dynamically and run into a problem. If you set max power then I believe it reduces the automatic switching.

  • Well, I set "prefer maximum power" and Godot still froze.
    But at least it didn't give me a BSoD this time. :s

  • cyberealitycybereality Posts: 1,053Moderator

    Is this happening on a specific project or on multiple projects? Try opening Godot from the command line, you should get a console window that may show an error when it freezes. This could help find the problem.

  • It happens on multiple projects. I'll try opening Godot from the command line, though.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file