The Godot Community Forums are back up and running! Please read the the announcement post for important information on what happened. Thanks!

When importing 3D models into godot scene, the model is huge!

UnknownUserUnknownUser Posts: 0

as the title suggests when I bring the model into the scene its only massive and I dont know how to get it to the correct size

Comments

  • cyberealitycybereality Posts: 1,053Moderator

    How did you export it and what units were you using? By default, Godot uses 1 unit = 1 meter. Some 3D modelling apps my allow you do adjust the scale on export in case they are in different units (for example, I think Unreal Engine uses 1 cm).

  • Hello, I dont know I wanted to use a ready made 3d model since Im still learning but it seems to be every gltf file format seems to make a massive model Im not sure why

  • MegalomaniakMegalomaniak Posts: 2,908Admin

    Most have probably been exported at such size, since they either target being used in max/maya or unreal engine. A free solution would be to use blender, import into it and export out with resizing enabled in the importer and exporter.

    You would likely have to read up on documentation for the importers and exporters, but if you won't be modifying the assets then you shouldn't really need to learn any other aspects of blender.

  • Thank you very much, been banging my head around on why it does this didn't know godot has a different system.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file