Google Play Store release problem

Nano-95Nano-95 Posts: 4Member
edited August 19 in Exporting

Hey everyone,

I'm finally getting to the point where i'd like to deploy my game to the play store to be tested by friends, volunteers, etc. But I ran into a problem when I tried to upload the apk... It doesn't support the right API level.

"Your app currently targets API level 28 and must target at least API level 29 to ensure it is..."

I was wondering if I could get some guidance on how to do that.
Thanks in advance!


Tags :

Best Answer

  • Nano-95Nano-95 Posts: 4
    Accepted Answer

    Hey everyone,

    I hope this helps someone in the future, or myself if i happen to forget how I fixed it.

    I essentially followed these steps, even though i had already completed all of it in order to export an .apk in the first place and test on my phone up until wanting to get the app to the Play Store... so if you've also gotten your app to your android device already, you're likely just in need to create a custom build.

    The first step is going to project > Install Android Build Template... and completing the process which does not take long. For quick access to the files that were created, just go right back to project > Install Android Build Template... and click Show in File Manager

    You should be taken to the 'Android' folder that contains a 'build' folder and 2 other files.

    go to build, and right-click on the config file (config.gradle) and open using notepad or notepad++ (or any text editor)

    You should see this:

    ext.versions = [
    androidGradlePlugin : '3.4.2',
    compileSdk : 28,
    minSdk : 18,
    targetSdk : 28,
    buildTools : '28.0.0',
    supportCoreUtils : '28.0.0'
    ]

    For me the error I was getting was talking about the target API needing to be 29 rather than 28. So i changed it to this:

    ext.versions = [
    androidGradlePlugin : '3.4.2',
    compileSdk : 29,
    minSdk : 18,
    targetSdk : 29,
    buildTools : '29.0.2',
    supportCoreUtils : '28.0.0'
    ]

    NOTE: buildTools was set to that because in my directory containing my build-tools, the latest one was the 29 one.

    Once that's done, you are close to creating a custom build. Go back to Godot, and go to Project > Export...

    Find the section that has Use Custom build

    If you can, go ahead and hit Export Project, Otherwise you have to go back to Editor > Editor Settings...

    In your tabs on the left side, find the Android tab under the Export section. You must get the Custom Build Sdk Path. I honestly was not quite sure which one was right, but this worked for me (of course it is relative to my system, so yours will be different but might be similar.

    C:/Users/xxx/AppData/Local/Android/Sdk

    Again, for reference, this is what led me to the solution...
    https://docs.godotengine.org/en/latest/getting_started/workflow/export/android_custom_build.html

    Thanks!

Answers

  • nibbaninibbani Posts: 10Member

    how did you export?
    also maybe this could help? https://developer.android.com/guide/topics/manifest/uses-sdk-element

  • Nano-95Nano-95 Posts: 4Member
    edited August 19

    @nibbani said:
    how did you export?
    also maybe this could help? https://developer.android.com/guide/topics/manifest/uses-sdk-element

    Hey Nibbani,

    I exported by going to Project > Export... within Godot.

    I don't understand many of those docs because i don't see any files that contain any < android > element...

  • cyberealitycybereality Posts: 1,049Moderator

    From what I understand, the Android API level is built into the export template. I tried searching for a solution, but I didn't find anything promising. Maybe if you got the source code and built the export template yourself, you could change the API level. Not sure.

    https://docs.godotengine.org/en/stable/development/compiling/compiling_for_android.html

  • Nano-95Nano-95 Posts: 4Member

    @cybereality said:
    From what I understand, the Android API level is built into the export template. I tried searching for a solution, but I didn't find anything promising. Maybe if you got the source code and built the export template yourself, you could change the API level. Not sure.

    https://docs.godotengine.org/en/stable/development/compiling/compiling_for_android.html

    I appreciate the help! I'll take a look at that and report if anything comes from it.

  • Nano-95Nano-95 Posts: 4Member
    Accepted Answer

    Hey everyone,

    I hope this helps someone in the future, or myself if i happen to forget how I fixed it.

    I essentially followed these steps, even though i had already completed all of it in order to export an .apk in the first place and test on my phone up until wanting to get the app to the Play Store... so if you've also gotten your app to your android device already, you're likely just in need to create a custom build.

    The first step is going to project > Install Android Build Template... and completing the process which does not take long. For quick access to the files that were created, just go right back to project > Install Android Build Template... and click Show in File Manager

    You should be taken to the 'Android' folder that contains a 'build' folder and 2 other files.

    go to build, and right-click on the config file (config.gradle) and open using notepad or notepad++ (or any text editor)

    You should see this:

    ext.versions = [
    androidGradlePlugin : '3.4.2',
    compileSdk : 28,
    minSdk : 18,
    targetSdk : 28,
    buildTools : '28.0.0',
    supportCoreUtils : '28.0.0'
    ]

    For me the error I was getting was talking about the target API needing to be 29 rather than 28. So i changed it to this:

    ext.versions = [
    androidGradlePlugin : '3.4.2',
    compileSdk : 29,
    minSdk : 18,
    targetSdk : 29,
    buildTools : '29.0.2',
    supportCoreUtils : '28.0.0'
    ]

    NOTE: buildTools was set to that because in my directory containing my build-tools, the latest one was the 29 one.

    Once that's done, you are close to creating a custom build. Go back to Godot, and go to Project > Export...

    Find the section that has Use Custom build

    If you can, go ahead and hit Export Project, Otherwise you have to go back to Editor > Editor Settings...

    In your tabs on the left side, find the Android tab under the Export section. You must get the Custom Build Sdk Path. I honestly was not quite sure which one was right, but this worked for me (of course it is relative to my system, so yours will be different but might be similar.

    C:/Users/xxx/AppData/Local/Android/Sdk

    Again, for reference, this is what led me to the solution...
    https://docs.godotengine.org/en/latest/getting_started/workflow/export/android_custom_build.html

    Thanks!

  • BTHQBTHQ Posts: 3Member

    Nano-95, THANK YOU so much for this fix!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file