Mouse Cursor a little bit off and not exactly on grid tile !

Hey there !

Got a new Notebook Surface Pro 3 --> https://www.amazon.de/Microsoft-Surface-Tablet-Intel-Silber/dp/B07BH8XF79

--> https://snipboard.io/taCE6h.jpg <3

For some reason the mouse cursor seems a bit off i have grid snap on can you may help me ? I think it has something to do with the strange resolution of the Surface 3.

Thanks in advance ! <3

Comments

  • MegalomaniakMegalomaniak Posts: 2,738Admin

    Might have something to do with the high-DPI setting. Quite possibly a bug.

  • Lovingsoul1337Lovingsoul1337 Posts: 5Member

    Even in the drop down menus...can you may help me ? If i put the dpi to 100 % instead off 200 %(recommended by windows 10) my whole notebook seems to be laggy...would be great if someone can help me here !

  • TwistedTwiglegTwistedTwigleg Posts: 2,810Admin

    I don't really know how much help we can provide since we do not have the device causing the issue. Do you get this issue on any other programs? If not, then it is probably a Godot engine bug that should be reported to the Godot GitHub repository , assuming a bug on the issue has not already been made.

    Additionally, does the issue only occur with grid snap being on, or does it also occur when grid snapping is off? Have you tried using a different input device (a different mouse, etc) to rule out whether it is causing the issue? Finally, have you tried enabling/disabling high-DPI mode in Godot? The DPI setting is in the editor or project settings in the Godot editor, but I don't remember which right off.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file