scons not compiling Godot

stebulbastebulba Posts: 11Member
edited July 24 in General Support

I am on Ubuntu 16.04 LTS
my command : scons -j8 platform=x11
Result:

~$ scons -j8 platform=x11
> Python 3.5.2 (default, Jul 17 2020, 14:04:10) 
> [GCC 5.4.0 20160609] on linux
> Type "help", "copyright", "credits" or "license" for more information.
> ->>> 

I fallow instructionhttps://docs.godotengine.org/en/stable/development/compiling/compiling_for_x11.html
What I should do ?

Comments

  • TwistedTwiglegTwistedTwigleg Posts: 2,810Admin
    edited July 24

    Do you have scons installed? Also, which version/branch of Godot are you trying to compile? master or 3.2?

    Edit: After installing scons (if you have it installed), did you reboot your computer? I think I had to do that on my PC before the scons command worked.

  • stebulbastebulba Posts: 11Member
    edited July 24

    When I execute" scons " anywhere, I got the same result. The Godot version doesn't matter. Scons is installed from long time ago but don't look to do his job.

  • stebulbastebulba Posts: 11Member
    edited July 24

    OK I removed scons and re-installed it. That's work. Thank you for your help. To ask me if scons installed, give me the idea to reinstall it.
    But I got a new issues ...
    {standard input}: Fatal error: can't close platform/x11/export/export.x11.tools.64.o: No space left on device
    But that is easy to fix it ;)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file