What's the best format for 3D Model distribution for use in Godot?

BrendleBrendle Posts: 6Member
edited July 3 in 3D

(EDIT - I figured out how to fix this so I'm going to change this thread to a different title for a different topic, but I'll leave my original post here in case anyone else has the same issue. New topic / question of mine is in the second post.)

Original title of this thread - How do make colours in Blender and Godot the same?

Hi everyone,

I'm new to Godot and is this my second post here. When I import a 3D model into Godot from Blender, the colours are quite different, sorry does anyone here know how to fix that? I don't mind changing settings in Blender, Godot or both, though I'd prefer it if they were changed in Blender, so no changes would have to be made in a default, new Godot project (after import).

The first image is from Blender, the second is Godot and the third is the tiny .png palette I used to colour the cube in UV Editing mode.


EDIT - Nevermind. Spent ages on this yesterday but I figured it out today. On the top right of the window in Blender, there are icons for different 'Viewport shading' modes, I had it set to 'Display in Solid Mode'. Changing it to 'Display in Material Preview Mode' fixed my issue.

Now the colours are very similar, they aren't exactly the same but I'm sure this will be because they're different pieces of software, exporter quirks, scene lighting differences or all of the above. Now all I'd like to figure out is how to make the colours not so ugly.


  • BrendleBrendle Posts: 6Member
    edited July 3

    Slightly Different Topic

    If I was to distribute 3D models for sale or for free for use in Godot, which format would be best? A Godot scene with the model inside it, so it can be added to peoples projects, or simply a glTF file?

  • MegalomaniakMegalomaniak Posts: 2,785Admin

    For static environmental pieces I'd say wavefront .obj is fine. For rigged and animated models glTF .glb.

  • BrendleBrendle Posts: 6Member


  • hzzzlnhzzzln Posts: 6Member

    It also kind of looks like you have the cavity effect enabled in Blender's viewport settings:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file