Testing Forum: Forum for testing new changes.

TwistedTwiglegTwistedTwigleg Posts: 2,663Admin
edited June 22 in Forum Chat

Hey everyone!

I have setup a subdomain here on the forums so we plugins and changes can be tested by everyone before they go live on the "real" forums. This will allow us to get feedback from everyone, while also having a live forum for testing purposes. The idea is that the subdomain will mirror the forums, but will have experimental features applied, plugins enabled/disabled, and changes that are not present currently in the main forum for whatever reason.

This post will be updated as changes to the testing forum are made.

Below is a list of the changes that are currently only on the test forum:

  • The Rich post editor is enabled! This gives a much sleeker, more streamline way to post that does not require learning markdown. Additionally, it also has better Vanilla support and allows us to move away from legacy features.
    • Everything should work exactly like it does now, including support for Imgur, which was one of the barriers that initially made using the Rich post editor impossible. That said, please let us know if anything is not working as expected!
    • This change will be applied to the main forums on: Unknown - testing still required.

(Last updated 06/22/2020)

You can find the link to the test forum here: testing.godotforums.org

You can find the link to go back to the non-testing forum here: www.godotforums.org

Please take a look and reply here with any feedback you might have! Thanks :smile:


Tags :

Comments

  • TwistedTwiglegTwistedTwigleg Posts: 2,663Admin

    You can tell if you are on the testing forum by checking the title. Instead of saying Godot Forum, it should instead show the following:

    Hopefully that makes it a little easier to tell which forum is which.

  • cyberealitycybereality Posts: 927Moderator

    The test editor doesn't really work for me. I was not able to upload images, and I couldn't figure out how to post code. Is it supposed to be working or still in progress?

  • TwistedTwiglegTwistedTwigleg Posts: 2,663Admin
    edited June 23

    @cybereality said:
    The test editor doesn't really work for me. I was not able to upload images, and I couldn't figure out how to post code. Is it supposed to be working or still in progress?

    How were you not able to upload images? Does the add images button not work? The images button in the editor itself might not be working, I had not tried testing it. It might be related to the file permissions, which I recently learned did not include image files (I still need to change that).

    You can post code by selecting the code icon on the right side of the paragraph containing the code. Edit: Here's an image showing where the options are:

    Though admittedly, the code editing experience is not quite like what I expected. Tabs are not working, at least not for me, and the cursor jumped around a bit. However, the Rich editor is official supported by Vanilla and is the only editor they are currently still supporting...

  • MegalomaniakMegalomaniak Posts: 2,649Admin
    edited June 23

    Hmm, both connected to the same DB instance?

    Edit, yep. Clearly the case. Better be careful. :mask:

  • cyberealitycybereality Posts: 927Moderator

    Yeah, I just noticed my test thread is on the real public forum.

  • TwistedTwiglegTwistedTwigleg Posts: 2,663Admin
    edited June 23

    @Megalomaniak said:
    Hmm, both connected to the same DB instance?

    Edit, yep. Clearly the case. Better be careful. :mask:
    And @cybereality said:
    Yeah, I just noticed my test thread is on the real public forum.

    Fixed! Now the forums use different DB instances. :smile:

    I added a warning noting that all posts that are unique to the testing forum will be deleted (or rather, they will not be merged into the main forum, but I figure deleted gets the gist across).

    I also moved the deleted the test thread from this forum, so it is only on the testing forum instance.

    (Edit: For now, I made this post a pinned announcement so it is more visible. I figure after a few days, it can be moved back to just an ordinary announcement)

  • MegalomaniakMegalomaniak Posts: 2,649Admin

    Pretty sure it's the same issue as last time, but Add Images just gives me Body is required error.

  • TwistedTwiglegTwistedTwigleg Posts: 2,663Admin

    @Megalomaniak said:
    Pretty sure it's the same issue as last time, but Add Images just gives me Body is required error.

    I think it is because of how I modified the Imgur plugin to inject the HTML with the image. Unfortunately, finding good documentation on how to add HTML (or anything really) to the Rich post editor was hard to find. I only recently learned that it uses a library called Quill, which in turn allowed me to get something working with the Imgur plugin.
    I'll try to fix the issue this weekend.

  • TwistedTwiglegTwistedTwigleg Posts: 2,663Admin

    Alright, I finally had enough time to set down and work on fixing the Imgur plugin. The issue turned out to be how I was getting the cursor position, which was causing all sorts of issues. Now I am getting the cursor position correctly, and I cannot get the Body is Required error anymore when using the Add Images button.
    I also added CSS to remove the add images button from the bottom bar of the Rich Post editor, so the only way to upload images, without modifying the CSS, is to use the Imgur plugin.

    @Megalomaniak, @cybereality - once you guys have a chance, do you mind checking to see if the error is gone on your end?

  • MegalomaniakMegalomaniak Posts: 2,649Admin

    Seems to work. I wonder if we could replace the editors image button with ours/imgur plugins. It's fine where it is now but might be more fitting there perhaps?

  • TwistedTwiglegTwistedTwigleg Posts: 2,663Admin

    @Megalomaniak said:
    Seems to work. I wonder if we could replace the editors image button with ours/imgur plugins. It's fine where it is now but might be more fitting there perhaps?

    Awesome!
    Yeah, we might be able to either add our own button, or hijack the default button so it uses the plugin instead. Definitely something to look into.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file