Imported gltf file not showing in editor

xJM27xxJM27x Posts: 2Member
in 3D

Hello!
I need help with importing a 3d file I downloaded online.
I can open the file with my 3d viewer app without a problem. On Godot, I can see the mesh on the inspector tab but they just don't seem to show up in the editor.

You can download the file here (I use the autoconverted format):
https://sketchfab.com/3d-models/-mt-everest-128f43bac58e4798951bb309c64f328e

Comments

  • MegalomaniakMegalomaniak Posts: 2,645Admin
    edited June 19

    I've seen an issue with importing gltf models where the static model doesn't show up since in the import settings it's set to import an animated object. Try toggling animation related settings off and re-importing(the import tab visible next to the scene tree tab in your screenshot).

  • TwistedTwiglegTwistedTwigleg Posts: 2,655Admin

    Additionally, make sure the object's scale isn't so large or so small that you cannot see it. The easiest way to check if this is happening is to select the object/mesh and press the F key to focus on it, which should scale the camera relative to the object's bounding box.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file