Compiling errors

phonetextphonetext Posts: 1Member
edited June 13 in General Support
scons platform=android

scons: Reading SConscript files ...
Building for Android, platform android-24 (armv7) (with NEON)
Checking for C header file mntent.h... (cached) yes
scons: done reading SConscript files.
scons: Building targets ...
[Initial build] Compiling shared ==> platform\android\os_android.cpp
[Initial build] Compiling shared ==> platform\android\file_access_android.cpp
[Initial build] Compiling shared ==> platform\android\audio_driver_opensl.cpp
[Initial build] Compiling shared ==> platform\android\file_access_jandroid.cpp
[Initial build] Compiling shared ==> platform\android\dir_access_jandroid.cpp
[Initial build] Compiling shared ==> platform\android\thread_jandroid.cpp
[Initial build] Compiling shared ==> platform\android\net_socket_android.cpp
[Initial build] Compiling shared ==> platform\android\audio_driver_jandroid.cpp
[Initial build] Compiling shared ==> platform\android\java_godot_lib_jni.cpp
[Initial build] Compiling shared ==> platform\android\java_class_wrapper.cpp
[Initial build] Compiling shared ==> platform\android\java_godot_wrapper.cpp
[Initial build] Compiling shared ==> platform\android\java_godot_io_wrapper.cpp
[Initial build] Compiling shared ==> platform\android\jni_utils.cpp
[Initial build] Compiling shared ==> platform\android\android_keys_utils.cpp
[Initial build] Compiling shared ==> platform\android\display_server_android.cpp


b'In file included from platform\\android\\display_server_android.cpp:43:\r\n.\\drivers/vulkan/rendering_device_vulkan.h:44:10: fatal error: \'vk_mem_alloc.h\' file not found\r\n#include "vk_mem_alloc.h"\r\n         ^~~~~~~~~~~~~~~~\r\n1 error generated.\r\n'


scons: *** [platform\android\display_server_android.os] Error 1
scons: building terminated because of errors.

I also tried with platform=windows

scons platform=windows

scons: Reading SConscript files ...
Configuring for Windows: target=debug, bits=default
Found MSVC compiler: amd64
Compiled program architecture will be a 64 bit executable (forcing bits=64).
Missing environment variable: WindowsSdkDir
Missing environment variable: WindowsSdkDir
YASM is necessary for WebM SIMD optimizations.
WebM SIMD optimizations are disabled. Check if your CPU architecture, CPU bits or platform are supported!
Checking for C header file mntent.h... (cached) no
scons: done reading SConscript files.
scons: Building targets ...
[Initial build] Compiling ==> platform\windows\godot_windows.cpp
godot_windows.cpp
!D:\temp\godot\core/typedefs.h(34): fatal error C1083: Cannot open include file: 'stddef.h': No such file or directory
scons: *** [platform\windows\godot_windows.windows.tools.64.obj] Error 2
scons: building terminated because of errors.

I have installed:
Python 3.8
Visual Studio
Windows SDK 10 (from Visual Studio)
Scons

Comments

  • TwistedTwiglegTwistedTwigleg Posts: 2,629Admin

    (Reformatted and moved to the general support category)

  • TwistedTwiglegTwistedTwigleg Posts: 2,629Admin

    Welcome to the forums @phonetext!

    You are building from master, correct?

    With master, you will need to have Vulkan drivers installed on your computer, if you do not already. AS far as the error, it looks like it has something to do with a standard library file (stddef), so I would ugess that it is something to do with the C++ compiler you are using. I would double check the compiling instructions on the Godot documentation and see if there is anything there you have missed.

    For Android, I do not think there is support for Godot 4.0 on Android just yet. While Android does have Vulkan support, I believe it has not been implemented as of right now. OpenGLES 2 and/or OpenGLES 3 support will also be part of Godot 4.0, but neither has been implemented just yet. I think Godot 4.0 isn't quite ready for Android yet.
    That said, I could be completely wrong about this! I have not tried to compile for Android on with the Godot 4.0, nor have I been keeping too close of an eye on what is happening on that front. However, based on the error from trying to build for Android, it would appear that Vulkan support has not yet been implemented.

  • CalinouCalinou Posts: 409Admin Godot Developer

    For future reference, check this tracker issue.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file