TextureAtlas not working for Particles2D?

EzPizzaEzPizza Posts: 7Member
in 2D

I'm trying to use a texture atlas with Particles2D. I want to use a specific particle texture from a .png file with multiple particles on it. The issue is: When I use an atlas with a marked region, it will still display the entire texture file at once. Am I doing something wrong or is this a bug?

Here is a screenshots to clarify.

Comments

  • boruokboruok Posts: 14Member

    Hi.
    1. Clear your atlas texture settings and simple drag and drop your sprite into texture .
    2. In CanvasItem-section click Material -> NewCanvasItemMaterial.
    3. Check Particles Animation.
    4. Specify how many horizontal and vertical frames you have in that sprite.
    5. Go into Process Material -> Material.
    6. Scroll Down and find "Animation Section" -> Offset.
    7. Specify wich frame you whant.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file