Pixelated 2D sprites

FistedWaffleFistedWaffle Posts: 16Member
edited March 3 in 2D

So my game consists of a basic background (3840 x 2160) image and some 2D sprite images.For some reason whenever I import 2D images as sprites onto my scene , they look pixelated in the viewport aswell as in test mode.I know its not the texture quality of the sprite as my sprites are 1024x1024 or above ,in resolution.Ive tried turning off filter and reimported all my sprites but it didn't help. The only way I've somewhat solved my problem is by enabling mipmaps on my textures.Now they look fine on a 1080p monitor , but on higher resolutions ( I tested on my MacBook Retina display) , they appear blurry (not pixelated just BLURRY).
Ive attached a screenshot of the test gameplay to demonstrate.The first sprite at the bottom doesn't have mipmaps enabled and its very pixelated , the rest of them do have mipmaps but they're somewhat blurry.Anyone know what's going on here?

Comments

  • MegalomaniakMegalomaniak Posts: 2,027Admin

    Looking at the numbers on the chips the 50 looks the crispiest to me. I wonder if it's to do with the angle it's at compared to other numbers/chips. Have you tried the Anisotropic checkbox in addition(together with) to the Mipmaps?

  • FistedWaffleFistedWaffle Posts: 16Member
    edited March 3

    I've just tried enabling anisotropic but it doesn't seem to do much. My problem seems to only happen on resolutions higher than 1080p.
    When I move the test window to my 2nd monitor wich is 1080p everything looks perfectly fine with mipmaps enabled , but again the same pixelation happens without mipmaps.The attached screenshot is from my 1080p monitor. My game will mostly be running on 1080p , but I would like to support up to 4k :) I would also like to add that in project settings my game is set to 3840 x 2160 , So it may be the downscaling that is causing this? idk

  • MegalomaniakMegalomaniak Posts: 2,027Admin

    Whats the resolution of your chip sprites?

  • FistedWaffleFistedWaffle Posts: 16Member
    edited March 3

    Update: I just tested my game on a 4k tv and the chips with mipmaps enabled look perfectly fine but chip number 1(no mipmaps) is still a bit pixelated , so I guess its just my MacBook that makes them look fuzzy for whatever reason xD. Soo I guess my problem is solved , at least when using mipmaps.Although I still don't understand why the chips are pixelated without mipmaps.The chips all have the same resolution at 188x188 and they're unscaled.

  • MegalomaniakMegalomaniak Posts: 2,027Admin
    edited March 3

    From quick googling, most examples tend to only show 3D graphics/cases, but here's one that from a quick glance seems to be a bit more in depth, perhaps it helps:

    https://mynameismjp.wordpress.com/2012/10/21/applying-sampling-theory-to-real-time-graphics/

    Extremely basic TL;DR here(in godot) is that mipmaps disabled is just straight-up nearest neighbor sampling.

  • FistedWaffleFistedWaffle Posts: 16Member

    Thanks ! I think I understand it now for the most part !

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file