Godot 3.1.2: Black lines / borders around Sprite

DominoDevDominoDev Posts: 4Member
edited January 14 in 3D

[Edit: I already noticed I accidently put this into the discussions forum, it doesn't seem like I can delete/ remove it.
This question might work as a discussion too though, so I'll keep it here for now.]

In Godot 3.1.2 using OpenGL ES2, black borders/ lines seem to form around some sprites I have imported. Usually they appear on top of the sprite but can also "border" around it.

Being new to Godot development but coming from Unity I expect I did something wrong in the import or that the texture settings aren't set correctly. But so far I haven't been able to find any setting that resolves this issue.

So my question is: where can I find texture/image settings that can resolve this issue? Or if the issue stems from another source, how can I make sure that the images are being displayed without the black lines? (Bonus question: Is there also a way/ setting to display tiles in the Y-Axis non-blurry?)

(I'm pretty new to the Godot Forum so if my question is missing some details please let me know :) )


Tags :

Comments

  • MegalomaniakMegalomaniak Posts: 1,835Admin

    From the looks of it at a glance I'd wager you left no empty margin at the edges in those images so my guess is it's mipmapping causes a sort of a bleed over. Could be wrong though.

    Would be good if you included a screenshot of the import tab for the asset perhaps.

  • cyberealitycybereality Posts: 561Member

    I've found changing Compress Mode to Lossless on the texture import settings will fix this, but I don't know if that comes with any performance penalty.

  • DominoDevDominoDev Posts: 4Member

    @Megalomaniak said:
    From the looks of it at a glance I'd wager you left no empty margin at the edges in those images so my guess is it's mipmapping causes a sort of a bleed over. Could be wrong though.

    Would be good if you included a screenshot of the import tab for the asset perhaps.

    Well your wager was spot on, creating space around the assets did the trick. Thanks :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file