No sound on iOS/iPhone

ImerionImerion Posts: 15Member

Hi everyone! I have a problem that I just can't seem to figure out. I have a project that should play a sound. I'm using a normal AudioStreamPlayer with a .wav file. When I run the project on my PC, running Linux, sound works great. But when I export for iOS I get no sound at all no matter what I do. Godot is version 3.1 and the iOS App runs fine otherwise. I have tried different wav-files as well as switching from stereo to mono.

Is there any known errors with sound on iOS, or have I simply missed something? Any help would be appreciated! :)

Comments

  • ImerionImerion Posts: 15Member

    It might be when I turn Audio Input on in the Project Settings. Odd, but turning it off made the sound work.

  • MegalomaniakMegalomaniak Posts: 2,887Admin
    edited August 2019

    .wav is a container. It's likely a codec issue, i.e. whatever codec you have used isn't supported in iOS I guess? Try different audio codec, or different format altogether perhaps?

    https://en.wikipedia.org/wiki/WAV#Comparison_of_coding_schemes
    https://stackoverflow.com/questions/38128165/is-wav-file-supported-on-ios

    edit: I see that you got it working. I wonder if it was just an audio channel buffering issue or something. Seems odd to me.

  • ImerionImerion Posts: 15Member

    Yeah, it really is odd. I tried with various wav codecs as well as ogg-files without result, but once I turned off Audio Input they all worked. Thanks anyway for your post, that information might be useful in the future. I thought that as long as the file played on my computer it would play on iOS, but now I know better. :)

  • gnefnapgnefnap Posts: 3Member

    I have the same issue here in Godot 3.2.1. I just wrote a detailed thread and waiting for approval.

    Turning off Audio Input shouldn't affect playing sound(Audio Output) I guess, but it will ban Mic record(Audio Input), iOS won't even ask permission for mic recording if turning off Audio Input. The same project works on Android very well. Maybe some kind of channel overlapping bug or did I miss anything else?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file