The Godot Community Forums are back up and running! Please read the the announcement post for important information on what happened. Thanks!

Knight's Path - Deckbuilding Roguelike

AeternuxolusAeternuxolus Posts: 11Member

I've been working on this project for a while now, and only recently decided on a name. Then I went and made a gameplay demo and uploaded it to Youtube, lol..

I'm currently working on a playable demo and plan to upload it to Itch.

You start the game by selecting one of the available knights, each with a different starting advantage. Every card is used up when played, so your managing your deck is just as important as managing your health. As you traverse through the lands, you will be able to meet various denizens of the world and explore dungeons filled with monsters, to earn rewards to help you on your quest. Everything after you start the game is randomly generated, allowing each play through to be a different experience.

I appreciate any comments and/or feedback~

Tags :


  • kryzmakkryzmak Posts: 109Member

    Sounds like an interesting concept and I like your artworks/style. Keep on the good work.

  • AeternuxolusAeternuxolus Posts: 11Member

    Thank you very much!

  • GogetaXGogetaX Posts: 77Member

    looks like one of those Flash based game.
    i guess you drew stuff on Flash? good work on that also ^^

  • AeternuxolusAeternuxolus Posts: 11Member

    Thanks. The drawings were done in a program called Ibis Paint and then imported into Godot to be animated.

  • GogetaXGogetaX Posts: 77Member
    edited May 2019

    a dungeon with deck of cards.. sounds familiar ^^

  • AeternuxolusAeternuxolus Posts: 11Member

    I have a playable demo of my game on my Itch game page.

    It will be updated regularly as I switch between coding and drawing.

    Comments and feedback are appreciated~

    Link to demo:

  • MegalomaniakMegalomaniak Posts: 2,909Admin
    edited June 2019

    Cannot read property 'getParameter' of undefined

    index.js:7 exception thrown: TypeError: Cannot read property 'getParameter' of undefined,TypeError: Cannot read property 'getParameter' of undefined
        at _glGetString (
        at __ZN15RasterizerGLES310initializeEv (wasm-function[44135]:51)
        at __ZN18VisualServerRaster4initEv (wasm-function[42569]:34)
        at __ZN13OS_JavaScript10initializeERKN2OS9VideoModeEii (wasm-function[45273]:2155)
        at __ZN4Main6setup2Ey (wasm-function[38016]:222)
        at __ZN4Main5setupEPKciPPcb (wasm-function[38018]:11551)
        at _main (wasm-function[20045]:35)
        at Object.RuntimeEnvironment.Module._main (
        at Object.callMain (
        at Engine.synchronousStart (
    callMain @ index.js:7
    index.html:241 Cannot read property 'getParameter' of undefined
    displayFailureNotice @ index.html:241
    index.js:7 **ERROR**: Condition ' !_start_success ' is true. returned: false
    put_char @ index.js:7
    index.js:7    At: main/main.cpp:1277:start() - Condition ' !_start_success ' is true. returned: false

    I'll try the demo from another computer later.

  • AeternuxolusAeternuxolus Posts: 11Member

    Is this coming from the web player?

    Please let me know if you run into the problem on your other computer as well.

  • MegalomaniakMegalomaniak Posts: 2,909Admin

    Yes, from the web player/browser console. Just booted the other system up so about to test it.

  • MegalomaniakMegalomaniak Posts: 2,909Admin
    edited June 2019

    So previously I was using opera on my laptop, but on my desktop with waterfox I just get this:

    OpenGL ES 3.0 Renderer: Mozilla  index.js:7:32479
    uncaught exception: abort(101). Build with -s ASSERTIONS=1 for more info.  (unknown)
    101  index.js:7:321182

    edit: I do notice that it claims to be using GL ES 3.0, I think you might want to try GLES 2 renderer if you can.

  • MegalomaniakMegalomaniak Posts: 2,909Admin
    edited June 2019

    Loads on chromium though.

    edit: ok, temporarily allowing the whole page through NoScript fixes it, however interestingly the only two things that I had blocked in NoScript were the google analytics and doubleclick(ads).

  • AeternuxolusAeternuxolus Posts: 11Member

    Thank you very much for testing. That's very odd that turning off NoScript temporarily can resolve the issue - I had someone tell me before that they had to reload the page a few times before it would work. Could it have been by chance that it loaded on a refresh caused by changing the blocking permissions?

    For myself, I tested it on Firefox and Chrome and haven't run into any issues, so it's nice to have others testing it as well. I will look into the GLES 2 renderer - I think I used whatever was default at the time. My understanding is that certain code might not play nice with the difference in rendering?

  • MegalomaniakMegalomaniak Posts: 2,909Admin

    Well, yeah there's some differences. Particles are handled by CPU in GLES2 rather than GPU for an example, but I doubt that is as relevant to your game. I do however recommend you make a copy of your project and then switch to the different renderer.

  • AeternuxolusAeternuxolus Posts: 11Member

    Thank you for the suggestion - I will make the shift today and see if I can put up a new demo soon.

  • AeternuxolusAeternuxolus Posts: 11Member

    I've changed it to GLES2 - but I think it might still have loading troubles. I had my friend test it and it took them a few refreshes before it would load.

    The game is also updated to version 0.3.0, with a lot of adjustments and additions.

    Comments, suggestions or feedback in general is appreciated~!

  • MegalomaniakMegalomaniak Posts: 2,909Admin
    edited June 2019

    Well, I didn't temporarily allow the whole page and it did load fine anyways this time.

    edit: I am getting this now though:
    Error: WebGL warning: framebufferRenderbuffer: bindRenderbuffer must be called before attachment to 8d00 index.js:7:260897

    That seems like something worth reporting to the tracker I suppose.

  • TwistedTwiglegTwistedTwigleg Posts: 3,131Admin

    Just played through and got to the last area before running out of cards. It was a lot of fun!
    I collected a fair amount of boost cards before I realized my deck wasn't infinite and I soon wouldn't be able to attack, but that was me being dumb and not paying attention. Once I got to the final destination on the map, I only had two attacks (both of which did no damage since they were weaker cards) and three/four boosting cards :lol:

    Great stuff @Aeternuxolus! I very much enjoyed playing it, and look forward to seeing the project progress!
    (Also, I don't know if I was using GLES2 or GLES3, but the game loaded fine for me on the first try and I had no visible issues)

  • AeternuxolusAeternuxolus Posts: 11Member

    I'm glad you enjoyed the game @TwistedTwigleg - thank you for trying out my game! And I appreciate you sharing your experience with the game too~!

    And thank you @Megalomaniak for helping me look into the error!

  • organicpencilorganicpencil Posts: 20Member

    Neat concept! Beat the boss on attempt #2

    -Tested on Firefox 67
    -Like others, the finite card mechanic caught me off guard at first
    -Slightly disappointed that subsequent search attempts would continue yielding ambushes

    Axe 4 lyfe

  • AeternuxolusAeternuxolus Posts: 11Member

    After a long time, I finally have a new build of my game uploaded.

    I recorded a new play through:

    The game is playable at in browser and it can also be downloaded.

    Notable changes for anyone who has played it before:
    The next action made by the enemy is now displayed, so defensive abilities have more value.
    Danger level is now shown as a number and reflects how like you can get ambushed, and such.
    I also added a command feature, that lets you use skills and items.
    There's also a shop now that you can spend the coins that you earn from battle.
    I also added attack cards that aren't part of the sword/spear/axe trinity.
    Clicking on a card name will show more details about the card.

    @organicpencil - I actually found out that my code wasn't working the way I wanted after reading your feedback. Ambushes shouldn't have been happening so much, so that's definitely fixed now. I actually thought that I replied to your comment back then, so I'm really sorry for that. Thank you for the feedback, it helped a lot!

    I'm currently working on a tutorial and also improving how things are explained in general.

    Any feedback is appreciated, thanks!

  • Great work! Just tried it out and and left feedback. This shows a lot of skill and potential, and I'll be following to see where you take it.

  • AeternuxolusAeternuxolus Posts: 11Member

    @Maaack - Thanks a lot for the feedback; I hope you enjoyed the game!

  • It was a pleasure!

    Have you tried posting the game to ? It's a tiny audience relative to, but their focus on Godot games might garner you more attention and feedback.

  • AeternuxolusAeternuxolus Posts: 11Member

    A Godot-focused game site sounds great - never heard of them before, but I'll be sure to check it out! Thanks!

Sign In or Register to comment.