What I'm doing wrong with sound ?

GarromOrcShamanGarromOrcShaman Posts: 214Member
edited November 2018 in Audio

I'm trying to play sound first time ever but it sounds very glitchy and loud (putting volume on bus lower does not help). I'm using pulse audio and file is 16 bit wav. What I'm doing wrong ? Is there anything I can do with it ? I tried to download song from internet to test if it isn't file, well, isn't. I did not configuret anything. Besides this I'm unable to put down volume from inspector. I tried slider on bus and amplify effect with negative volume as well as volume variable in stream player node.

To give you idea of what it sounds like.
This one is alright, it is from audio player
This one is, Eh, well, from GoDot
If you want to try it out. Here is file I used as resource
Now you know what I mean ? What I can do to make godot one sound well.
Thanks.
-Garrom


Tags :

Best Answer

  • TwistedTwiglegTwistedTwigleg Posts: 2,858
    Accepted Answer

    @GarromOrcShaman said:

    @TwistedTwigleg said:

    @GarromOrcShaman said:

    @TwistedTwigleg said:
    Have you tried converting the file into a Ogg file? I have used several Ogg files with Godot and have not had any problems.

    I downloaded the sample, imported it into a project with the default settings, and it sounded fine. I used Godot 3.0.6 on Windows 10.

    I listened to the Godot version, and yeah, it sounds strange. I think what is happening is that the audio is clipping, which is making it sound distorted. I would try converting the file to a Ogg in something like Audacity and see if that fixes it.

    The only other thing I can think of it maybe the audio settings somehow got messed up. Not sure if it will help, but here are the settings I had on the project I imported the sample to:

    Other than that, I'm not really sure, sorry!

    I already tried OGG, no change. However, my settings look different. First, I guess there is no WASAPI in linux, second, my settings have one more entry. Look.

    I'm using pulse audio with echo cancel module. I never had such problems before.

    Well, I guess we can more or less rule out the possibility of the file format being a issue.

    I think WASAPI is a Windows specific audio driver. I do not think that would make a difference, but you never know. The additional setting, Output Latency, should only make it where this is a slight delay when playing audio files.

    I tried running the audio sample through a AudioStreamPlayer2D testing each of the EQ modules (EQ, EQ6, EQ10, and EQ21) at a time. With each of the EQ modules, the audio was fine.

    Have you tried playing the sample in a new project? While I do not think the project is the problem, it would rule out another possibility.

    Later I'll boot into Linux and see if I can reproduce the error there. On Linux, you are using Godot 3.0.6 right?

    I just tryed new project and it was same. I composited music by myself in SunVox. You mentioned earlier that you are using Windows 10, I'm not expert but to me it looks like another Linux thing. Do you know who wrote pulse audio driver ? He/she may know what is happening. I think that there is possibility that something in file is wrong but music player is just made in way to deal with it while GoDot is not.

    Now we know it is not a project specific thing. As you said, I think it is a Linux specific issue.

    Unfortunately I do not know who wrote the pulse audio driver. However, I am starting to think this is a Godot Engine bug. If the sound file works fine on Windows but not on Linux, then it is almost certainly a bug.

    I took a look at the GitHub repository and found this issue. It seems he has the same problem when playing sounds on Linux. Unfortunately it looks like no one found a solution there and the issue has been dormant since August.

    I'll try running the audio sample in Linux once I have a chance and see if I get the same results.

Answers

  • TwistedTwiglegTwistedTwigleg Posts: 2,858Admin

    Have you tried converting the file into a Ogg file? I have used several Ogg files with Godot and have not had any problems.

    I downloaded the sample, imported it into a project with the default settings, and it sounded fine. I used Godot 3.0.6 on Windows 10.

    I listened to the Godot version, and yeah, it sounds strange. I think what is happening is that the audio is clipping, which is making it sound distorted. I would try converting the file to a Ogg in something like Audacity and see if that fixes it.

    The only other thing I can think of it maybe the audio settings somehow got messed up. Not sure if it will help, but here are the settings I had on the project I imported the sample to:

    Other than that, I'm not really sure, sorry!

  • GarromOrcShamanGarromOrcShaman Posts: 214Member

    @TwistedTwigleg said:
    Have you tried converting the file into a Ogg file? I have used several Ogg files with Godot and have not had any problems.

    I downloaded the sample, imported it into a project with the default settings, and it sounded fine. I used Godot 3.0.6 on Windows 10.

    I listened to the Godot version, and yeah, it sounds strange. I think what is happening is that the audio is clipping, which is making it sound distorted. I would try converting the file to a Ogg in something like Audacity and see if that fixes it.

    The only other thing I can think of it maybe the audio settings somehow got messed up. Not sure if it will help, but here are the settings I had on the project I imported the sample to:

    Other than that, I'm not really sure, sorry!

    I already tried OGG, no change. However, my settings look different. First, I guess there is no WASAPI in linux, second, my settings have one more entry. Look.

    I'm using pulse audio with echo cancel module. I never had such problems before.

  • TwistedTwiglegTwistedTwigleg Posts: 2,858Admin

    @GarromOrcShaman said:

    @TwistedTwigleg said:
    Have you tried converting the file into a Ogg file? I have used several Ogg files with Godot and have not had any problems.

    I downloaded the sample, imported it into a project with the default settings, and it sounded fine. I used Godot 3.0.6 on Windows 10.

    I listened to the Godot version, and yeah, it sounds strange. I think what is happening is that the audio is clipping, which is making it sound distorted. I would try converting the file to a Ogg in something like Audacity and see if that fixes it.

    The only other thing I can think of it maybe the audio settings somehow got messed up. Not sure if it will help, but here are the settings I had on the project I imported the sample to:

    Other than that, I'm not really sure, sorry!

    I already tried OGG, no change. However, my settings look different. First, I guess there is no WASAPI in linux, second, my settings have one more entry. Look.

    I'm using pulse audio with echo cancel module. I never had such problems before.

    Well, I guess we can more or less rule out the possibility of the file format being a issue.

    I think WASAPI is a Windows specific audio driver. I do not think that would make a difference, but you never know. The additional setting, Output Latency, should only make it where this is a slight delay when playing audio files.

    I tried running the audio sample through a AudioStreamPlayer2D testing each of the EQ modules (EQ, EQ6, EQ10, and EQ21) at a time. With each of the EQ modules, the audio was fine.

    Have you tried playing the sample in a new project? While I do not think the project is the problem, it would rule out another possibility.

    Later I'll boot into Linux and see if I can reproduce the error there. On Linux, you are using Godot 3.0.6 right?

  • GarromOrcShamanGarromOrcShaman Posts: 214Member

    @TwistedTwigleg said:

    @GarromOrcShaman said:

    @TwistedTwigleg said:
    Have you tried converting the file into a Ogg file? I have used several Ogg files with Godot and have not had any problems.

    I downloaded the sample, imported it into a project with the default settings, and it sounded fine. I used Godot 3.0.6 on Windows 10.

    I listened to the Godot version, and yeah, it sounds strange. I think what is happening is that the audio is clipping, which is making it sound distorted. I would try converting the file to a Ogg in something like Audacity and see if that fixes it.

    The only other thing I can think of it maybe the audio settings somehow got messed up. Not sure if it will help, but here are the settings I had on the project I imported the sample to:

    Other than that, I'm not really sure, sorry!

    I already tried OGG, no change. However, my settings look different. First, I guess there is no WASAPI in linux, second, my settings have one more entry. Look.

    I'm using pulse audio with echo cancel module. I never had such problems before.

    Well, I guess we can more or less rule out the possibility of the file format being a issue.

    I think WASAPI is a Windows specific audio driver. I do not think that would make a difference, but you never know. The additional setting, Output Latency, should only make it where this is a slight delay when playing audio files.

    I tried running the audio sample through a AudioStreamPlayer2D testing each of the EQ modules (EQ, EQ6, EQ10, and EQ21) at a time. With each of the EQ modules, the audio was fine.

    Have you tried playing the sample in a new project? While I do not think the project is the problem, it would rule out another possibility.

    Later I'll boot into Linux and see if I can reproduce the error there. On Linux, you are using Godot 3.0.6 right?

    I just tryed new project and it was same. I composited music by myself in SunVox. You mentioned earlier that you are using Windows 10, I'm not expert but to me it looks like another Linux thing. Do you know who wrote pulse audio driver ? He/she may know what is happening. I think that there is possibility that something in file is wrong but music player is just made in way to deal with it while GoDot is not.

  • TwistedTwiglegTwistedTwigleg Posts: 2,858Admin
    Accepted Answer

    @GarromOrcShaman said:

    @TwistedTwigleg said:

    @GarromOrcShaman said:

    @TwistedTwigleg said:
    Have you tried converting the file into a Ogg file? I have used several Ogg files with Godot and have not had any problems.

    I downloaded the sample, imported it into a project with the default settings, and it sounded fine. I used Godot 3.0.6 on Windows 10.

    I listened to the Godot version, and yeah, it sounds strange. I think what is happening is that the audio is clipping, which is making it sound distorted. I would try converting the file to a Ogg in something like Audacity and see if that fixes it.

    The only other thing I can think of it maybe the audio settings somehow got messed up. Not sure if it will help, but here are the settings I had on the project I imported the sample to:

    Other than that, I'm not really sure, sorry!

    I already tried OGG, no change. However, my settings look different. First, I guess there is no WASAPI in linux, second, my settings have one more entry. Look.

    I'm using pulse audio with echo cancel module. I never had such problems before.

    Well, I guess we can more or less rule out the possibility of the file format being a issue.

    I think WASAPI is a Windows specific audio driver. I do not think that would make a difference, but you never know. The additional setting, Output Latency, should only make it where this is a slight delay when playing audio files.

    I tried running the audio sample through a AudioStreamPlayer2D testing each of the EQ modules (EQ, EQ6, EQ10, and EQ21) at a time. With each of the EQ modules, the audio was fine.

    Have you tried playing the sample in a new project? While I do not think the project is the problem, it would rule out another possibility.

    Later I'll boot into Linux and see if I can reproduce the error there. On Linux, you are using Godot 3.0.6 right?

    I just tryed new project and it was same. I composited music by myself in SunVox. You mentioned earlier that you are using Windows 10, I'm not expert but to me it looks like another Linux thing. Do you know who wrote pulse audio driver ? He/she may know what is happening. I think that there is possibility that something in file is wrong but music player is just made in way to deal with it while GoDot is not.

    Now we know it is not a project specific thing. As you said, I think it is a Linux specific issue.

    Unfortunately I do not know who wrote the pulse audio driver. However, I am starting to think this is a Godot Engine bug. If the sound file works fine on Windows but not on Linux, then it is almost certainly a bug.

    I took a look at the GitHub repository and found this issue. It seems he has the same problem when playing sounds on Linux. Unfortunately it looks like no one found a solution there and the issue has been dormant since August.

    I'll try running the audio sample in Linux once I have a chance and see if I get the same results.

  • GarromOrcShamanGarromOrcShaman Posts: 214Member
    edited November 2018

    @TwistedTwigleg said:

    @GarromOrcShaman said:

    @TwistedTwigleg said:

    @GarromOrcShaman said:

    @TwistedTwigleg said:
    Have you tried converting the file into a Ogg file? I have used several Ogg files with Godot and have not had any problems.

    I downloaded the sample, imported it into a project with the default settings, and it sounded fine. I used Godot 3.0.6 on Windows 10.

    I listened to the Godot version, and yeah, it sounds strange. I think what is happening is that the audio is clipping, which is making it sound distorted. I would try converting the file to a Ogg in something like Audacity and see if that fixes it.

    The only other thing I can think of it maybe the audio settings somehow got messed up. Not sure if it will help, but here are the settings I had on the project I imported the sample to:

    Other than that, I'm not really sure, sorry!

    I already tried OGG, no change. However, my settings look different. First, I guess there is no WASAPI in linux, second, my settings have one more entry. Look.

    I'm using pulse audio with echo cancel module. I never had such problems before.

    Well, I guess we can more or less rule out the possibility of the file format being a issue.

    I think WASAPI is a Windows specific audio driver. I do not think that would make a difference, but you never know. The additional setting, Output Latency, should only make it where this is a slight delay when playing audio files.

    I tried running the audio sample through a AudioStreamPlayer2D testing each of the EQ modules (EQ, EQ6, EQ10, and EQ21) at a time. With each of the EQ modules, the audio was fine.

    Have you tried playing the sample in a new project? While I do not think the project is the problem, it would rule out another possibility.

    Later I'll boot into Linux and see if I can reproduce the error there. On Linux, you are using Godot 3.0.6 right?

    I just tryed new project and it was same. I composited music by myself in SunVox. You mentioned earlier that you are using Windows 10, I'm not expert but to me it looks like another Linux thing. Do you know who wrote pulse audio driver ? He/she may know what is happening. I think that there is possibility that something in file is wrong but music player is just made in way to deal with it while GoDot is not.

    Now we know it is not a project specific thing. As you said, I think it is a Linux specific issue.

    Unfortunately I do not know who wrote the pulse audio driver. However, I am starting to think this is a Godot Engine bug. If the sound file works fine on Windows but not on Linux, then it is almost certainly a bug.

    I took a look at the GitHub repository and found this issue. It seems he has the same problem when playing sounds on Linux. Unfortunately it looks like no one found a solution there and the issue has been dormant since August.

    I'll try running the audio sample in Linux once I have a chance and see if I get the same results.

    Sure, it is a bug. I'm going to issue it. Thanks for link, I haven't found it myself. Can you poke issue somehow ? After all, you are admin of forum, you are more important than me. I'm just mere user, my word does not weight much.

  • MegalomaniakMegalomaniak Posts: 2,773Admin

    On the issue tracker your word will hold as much weight as any of the rest of ours. This forum is community run, me and twisted are just regular users like the rest.

  • TwistedTwiglegTwistedTwigleg Posts: 2,858Admin
    edited November 2018

    @GarromOrcShaman said:
    Sure, it is a bug. I'm going to issue it. Thanks for link, I haven't found it myself. Can you poke issue somehow?

    I can add what I know to the issue and see if that helps, but outside of that there is not a whole lot I can do.

    I still need to test the Audio file on Linux and see what happens there, and then I'll post my findings on the GitHub issue.

    After all, you are admin of forum, you are more important than me. I'm just mere user, my word does not weight much.

    Outside of the forums, I am just a normal user like everyone else. I am no more important than anyone else, I just have some more responsibilities on these forums :smile:

    As far as I know, my word has no more weight than anyone else.
    That said, I'll still pitch in, if nothing else to see if I can help fix the issue.


    Edit: Alright, I posted what I know and what I figured out running Linux to the issue.

  • binogurebinogure Posts: 9Member

    This bug is reproducible on windows. I have players of my who have the very same issue.

  • GarromOrcShamanGarromOrcShaman Posts: 214Member

    @binogure said:
    This bug is reproducible on windows. I have players of my who have the very same issue.

    We had discussion here and ultimately amount of channels is responsible for this. To be more specific, uneven amount of channels like 1 in my case. Ask here or create new issue.

  • AlienAlien Posts: 2Member

    i still have the same issue.
    There is nothing there on "here" - link that i was able to understand and use to fix the problem.

  • TwistedTwiglegTwistedTwigleg Posts: 2,858Admin
    edited May 7

    I don't know how else to bring this up, so I apologize for going off-topic!

    @GarromOrcShaman - The email address associated with your account is not correct and the emails keep bouncing. Please send me an email so we can change the email address associated and allow you to access your account again. my email is on my profile and this topic. Thanks!

  • AlienAlien Posts: 2Member

    There is no bug. Somehow i solved it. I only use godot for a few days, this is my first game, so i don't really know what i did.I use buses too, with no effect because....
    On run time, the first sound that played (very loud and too scary for a baby game) was the one selected in the Inspector - Stream. I tryed to change the stream, with ANOTHER one, from inside the script in _ready function, but the FIRST scary sound did not stoped. (After the scream, the "another" was used ok.)
    Then i realized that, in the same script,
    in _ready function
    i autostarted a Timer (the one that emited that sound on timeout) before set the AudioStreamPlayer.stream="" (maybe the bus too?) , so the one that played was the one from the Inspector without the bus limiter or volume set. I was sure that 3 seconds on timer will be ok time to load the stream and bus, but....

    So , make sure that on runtime

    first AudioServer.set_bus_layout(something_bus) (in another parent node _ready funct, in my case)
    then set audioelement.stream = "something_stream" (in _ready function)
    only then started the timer (or other things ) that call to soundname".play" the sound on some timeout, etc , just to be sure it does not scream any more. (in the same _ready function)

    (at first, in panic, i erased the stream from the inspector, but now it does not matter if is there or not)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file